Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

com.sybase.scc.jmx.ManagedObjectGateway.err_invoke_op SCC agent db2v105:9999 does not know Sybase IQ version string. Something is wrong with the IQ Agent plug-in.

Hello All,

I am a student and just want to try my hands on SAP IQ. So i downloaded SAP for linux. I set up a Virtual machine on my windows and loaded the linux image onto the virtual machine. So far i have been successfully able to install SAP IQ, create database and so on. But I have only got as far as authenticating the agent after registering it. When i authenticate the agent it gives me the below error and obviously the authentication fails

"com.sybase.scc.jmx.ManagedObjectGateway.err_invoke_op SCC agent db2v105:9999 does not know Sybase IQ version string. Something is wrong with the IQ Agent plug-in."

So i searched on internet and followed the process mentioned in SAP info center under change request number 723112 however I am still unable to get it working. I would be really grateful if someone could help me ASAP. Thanks in advance

Former Member
replied

You can generate HTML query plans instead that contain more detail about a query by setting query_plan_as_html='on'; query_plan_after_run='on'; query_plan_detail='on'; etc.

What you will get is the time it took to get the number of rows and the detail.

As IQ is column-based, however, total IO cost is not the way to actually rank or rate IQ vs. other DBMS engines.  What you really want is time to user, as other variables such as IQ indexing, disk configuration and memory can affect query performance.

Chris

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question