Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Integration framework and Intercompany Addon for PO/SO setup

Hi All,

we are currently running V9.0 PL11, IC 2.0, latest patches.

Items replication is going nicely between the head office (HO1) and the one branch (BR1) the Intercompany module is currently setup for. I can track all replications, which happen 24/7 at the incredible speed of one item every 92 seconds (yes, i am being sarcastic here).

We have also configured the Head Office and Branch partners to sell, buy, deliver and receive items to and from each other.

We are at the stage where transactions need to be exchanged between the head office and the branch. So I created a Purchase Order from the Head Office (our setup requires branch and head office to buy items from each other indifferently) and I expected a Sale Order to be generated on the Branch side. But this did not happen.

Looking into the Integration Framework, I see that our "exchange" setup is based on a generic CXS Package Scenario, where only three steps are activated, Error Handling, GenericBIU.S and GenericBIU.R. I believe that Generic means "look at the 4 global data authorisations (Items, BOMs, Prices and Partners) and replicate whatever needs being replicated".

I have created my own ABC package scenario derived from the CXS package in order to run the PO/SO processes separately from the Items replication, therefore deactivating GenericBIUs from my own package.

But I am going around in circles trying to figure out what the correct setup is when I clearly need to configure the B1PO2B1SO R and S, and B1DELV2BAGRPO R and S.

Do I actually need to create 2 scenario packages here such as I would get

PackageScenario1 -> B1PO2B1SO.S having HO1 as the sender

PackageScenario1 -> B1DELV2B1GRPO.R having HO1 as the sender

PackageScenario2 -> B1DELV2B1GRPO.S having BR1 as the sender

PackageScenario2 -> B1PO2B1SO.R having BR1 as the sender

Is this the correct way? I don't see how HO1 and BR1 will exchange documents in this kind of setup. For some reason, I cannot specify a receiver. I have tried using the Apply processes, but when I try and activate it returns an error saying no sender system specified.

Any help very much appreciated!

Tags:
Former Member
Not what you were looking for? View more on this topic or Ask a question