Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Validate Process Dimension from BPC Administration Error - The process cannot access the file 'D:\Data\PC_MS\Data\Webfolders\PPM\System Files\OFFER.DIM' because it is being used by another process. -

Hi,

Every night we have many Data Manager Tasks that create/update our Dimensions (BPC 7.5 SP3) with new members using MakeDim.

From this morning an EVDRE IS returns an error "EVDRE encountered an error retrieving data from the Web Server".

The most important Dimension for this Input Schedule is called "Offer".

In the BPC Administration when I full process the dimension BPC tell me that "The process cannot access the file 'D:\Data\PC_MS\Data\Webfolders\PPM\System Files\OFFER.DIM' because it is being used by another process."

However, I try again and again until the process successfully finish.

I also tried to delete the newest member created in the DB Table and try all again but it doesn't works.
The only way that works now is manually process and process again until it works.


I don't like this workaround because it every works fine from 2010 to yesterday.

It seems that Offer.Dim is locked or open or something else.

I have tried restart Analysis Service, then I restart our server.
I read the Sap Notes 1861235 and 1618517 but they don't work.

How I can solve the problem? What's happened to Offer.DIM?

Thank you in advance and sorry for my english.
Marco

PS. All the others DM Tasks with the other Dimensions works fine. The parameters for the ModifyScript that I used is similar.

Tags:
replied

Hi Roberto!
Thank you for your reply.

Finally I solved the problem.
The fault is in a field of a new member in a source table (in another DB) that I put in the dimension.
The error was invisible at human eyes... maybe an invisibile special character or something else.
I modify the field in the source table and then the Data Manager task that upload data and create the dimension Offer works correctly!
And now, If I process the dimension from Adminstration Console, I have no error message!

Thank you for the support.

Marco

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question