Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

WebI report on SAP Mobile BI for iOS that contains a chart with element linking issue

Hi gurus. I have the following issue:

I have element linking based filters on my chart # 1 to filter values on chart # 2.  It worked fine on Ipad. And it worked fine on BI Launch Pad.

But after some time I check my webi report and it stopped working on IPAD.

Filters are not shown on the graph.

However it still works fine on BI LaunchPad

Have you faced this issue before?

Using: BI mobile 5.1.12

Before, example:

After some time, I opened sap mobile and it is not showing up the filter anymore

Now: We upgraded to SAP Bi Mobile 6.0.8.12 but issue persists.

Could you do the test?

Steps to reproduce:

  1. Create a simple Webi report with a table.
  2. Copy that table and paste it to the report.
  3. Turn the original table into a column chart
  4. Add element linking from the chart to table. (When user filters on the chart it should change the table as well)
  5. Test that the element link works in BI LaunchPad.
  6. Save the report to the Mobile category and test on iPad.
  7. Open report on iPad
  8. Tap chart bars. Yellow filters, that are supposed to show up, are not displayed.
Former Member
replied

Hi Erika,

Is this report element linking defined as 'All Objects' or 'Single Object' in Webi.

I ask this that report element linking on 'All Objects' is not supported yet. This support is expected to come in later releases.

However, if this is single object then it should be working. Can you verify this on latest app store build and confirm. If still it does not work for you, then please raise a support ticket for the same.

Regards,

Ashutosh

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question