Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Filter Condition doesnt work for Planned Orders in COOISPI

Hi everybody ,

I have a question regarding the Tcode : COOISPI ,

When we execute this Tcode for planned orders , we get a list of orders , but if we want to select a single planned order from the multiple orders seen  based on the filter condtion , the function doesnt support.

In Detail ,

If we have a list of 3 Planned Orders say for example

123

456

789

and I am applying a filter on '123' , the 123 order doesnt get picked but if i mention the same as ' *123 '

, it works .

At the table level , that is plaf internally converts it to 0000000123 , but still on doing this also , the filter condtion doesnt work .

It seems to wrok only with ' * ' as prefix.

Why does this happen ? Is this the standard way of working , I tried the same for the ProcessOrders in the same Tcode , there seems to be no issue , the filter works fine.

Please help , and let me know if it involves any customization(which doubt)

Thanks

Yamini

Former Member
replied

Hi Yamini,

This is SAP standard behavior. As well your observation is correct. The filter will work in process/production order.

If you see the table PLAF, the planned order is always with 10 digit. This is a standard setting. That's the reason  in the number range object if the planned order number is less than 10 digit, system will make it 10 digit adding zeroes as prefix.

If you see in the table level, you can see by giving the planned order but filter will work only if you put **. Filter works in a different logic than the table. This you know better that me being an ABAP person .

There are some other field like Object number which follow the same process.

At present I don't remember any SAP note is available or not.

Hope clarified.

Regards,

Krishnendu.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question