Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

NFe Serviço para a Prefeitura de Cotia

Boa tarde Prezados,

estamos implementando a Nota Fiscal de Serviço Eletrônica da Prefeitura de Cotia para um cliente através do SAP PI e ao tentarmos acessar o Web Service ServiceGinfesImpl_ConsultarNfseV3, ambiente de homologação, recebemos como retorno “HTTP 500” conforme imagem abaixo:



Segue o xml que estamos enviando para a Prefeitura de Cotia


<?xml version="1.0" encoding="utf-8" ?>

<nm:MT_ConsultaDeNFSe_Request xmlns:nm="http://www.nfse.com.br/Cotia/ConsultaDeNFSe/Sync" xmlns:prx="urn:sap.com:proxy:D72:/1SAI/TAS16E1AEB24E227A335020:702">

<arg0>

  <ConsultarNfseEnvio>

   <Prestador>

    <CNPJ>33069212000850

    </CNPJ>

    <InscricaoMunicipal>200265

    </InscricaoMunicipal>

   </Prestador>

   <NumeroNfse>369

   </NumeroNfse>

   <PeriodoEmissao>

    <DataInicial>2012-08-02

    </DataInicial>

    <DataFinal>2012-08-02

    </DataFinal>

   </PeriodoEmissao>

  </ConsultarNfseEnvio>

</arg0>

<arg1>Vazio</arg1>

</nm:MT_ConsultaDeNFSe_Request>


Também estou encaminhando o trace de rede que realizamos, porém ocorre um reset de conexão (reset - RST) pelo servidor da GINFES (Prefeitura de Cotia).

Alguém está conseguindo acessar os WebServices da Prefeitura de Cotia em homologação?

Alguém já implantou essa solução fazendo uso do SAP PI?

Vocês conseguem ajudar?

Abs,

Sérgio Salomão

Former Member
Former Member replied

Boa tarde Sergio, o negocio e meio complicado, vou tentar te ajudar, eu ja fiz para NFSe para prefeitura de Paulínia, onde e essa mesma empresa responsável a GINFES  , tem um forum deles também , mas o suporte não e muito bom, mas tem uns exemplos de notas hehe.

Para esse problema reportado vc devera editar o seu WSDL removendo o inicio de cada metodo ""ServiceGinfesImpl_" devera ficar assim ConsultarLoteRpsV3, quando o PI monta a massagem ele não acha o serviço no servidor da prefeitura se vc não editar o nome.

vc já fez o envio lote e assinatura das notas,pois e o serviço de consulta?

Tem um outro problema tb, que no mapeamento vc devera substituir os prefix que o PI coloca, aqueles Ns1, ns2 e etc, se não me engano vc devera substituir por "tipos:"

Espero ter ajudado em alguma coisa.

abs

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question