Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem with SUBMIT Statement

Hi All,

I have a BSP page written in HTML. I can get the HTML output of the BSP page in a internal table using standard report  rshttp20. In this 'HTTP_GET' FM is used which returns the HTML content of the BSP page.

But when I execute the report using submit statement with all required parameters (link is HTTPS and destination is SAPHTTPA) it is throwing error message "Connection to HTTPS://......: Document does not contain any data". I also created a new FM by copying entire code in report rshttp20 and executed FM by passing the same parameter values as of report. But still the same error persists.

I ran the report in the back ground and it is working as expected.

Any ideas...?

Thanks.

Former Member
Former Member replied

Hi,


Since parameters(uri,uri2) are case sensitive, while you filling these parameters , have you filled with concerning case ? Please check in debugger how these parameters are filled in direct calling and in back ground ?


Thanks & Regards,

Arun

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question