Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Exception caught by adapter framework: No configuration / default adapter specified for EDISeparator

Hello Experts,

I am configuring the scenario ( AS2 to EDISeparator and EDISeparator to IDOC ).

Can you please help me with the error below which is from the either the EDISeparator Receiver channel or the EDISeparator Sender channle.

09.06.2014 17:52:18.709InformationMessage is encrypted with 1.3.14.3.2.7 algorithm
09.06.2014 17:52:18.778InformationAS2 Message is signed with SHA1 (1.3.14.3.2.26) algorithm
09.06.2014 17:52:18.779InformationAS2 Message message signature is validated, signer ID is X509CertSelector: [ Serial Number: 1624063516 Issuer: CN=Mendelson AS2 TEST,OU=Integration,O=Mendelson,L=Berlin,ST=Unknown,C=GE matchAllSubjectAltNames flag: true ]
09.06.2014 17:52:18.784InformationAS2 document size is 350 Bytes
09.06.2014 17:52:18.784InformationPayload charset converted from ISO-8859-15 to ISO-8859-15
09.06.2014 17:52:18.785InformationB2B EdifactConverterModule : EDI format detected as EANCOM
09.06.2014 17:52:18.785InformationB2B EdifactConverterModule: Message will be read as ISO-8859-1.
09.06.2014 17:52:18.785InformationMP: processing local module localejbs/EdifactConverterModule
09.06.2014 17:52:18.785Information0}: The module-paramteter "eancom.subversion.prefix" is not set. Using default value "false"
09.06.2014 17:52:18.786Information0}: The module-paramteter "eancom..audit" is not set. Using default value "false"
09.06.2014 17:52:18.791InformationMP: processing local module localejbs/CallSapAdapter
09.06.2014 17:52:18.791InformationApplication attempting to send an XI message asynchronously using connection AS2_http://sap.com/xi/XI/AS2
09.06.2014 17:52:18.792InformationTrying to put the message into the send queue
09.06.2014 17:52:18.831InformationMessage successfully put into the queue
09.06.2014 17:52:18.831InformationThe application sent the message asynchronously using connection AS2_http://sap.com/xi/XI/AS2. Returning to application
09.06.2014 17:52:18.836InformationMIC (DeJYUIusqQj6aaYRASdHhAo+4J0=) is calculated using SHA1 algorithm.
09.06.2014 17:52:18.838InformationThe message was successfully retrieved from the send queue
09.06.2014 17:52:18.843InformationMessage status set to DLNG
09.06.2014 17:52:18.845InformationMDN is succcessfully signed with SHA1 (1.3.14.3.2.26) algorithm
09.06.2014 17:52:18.859InformationTrying to put the message into the send queue
09.06.2014 17:52:18.912InformationMessage successfully put into the queue
09.06.2014 17:52:18.913InformationThe message was successfully retrieved from the send queue
09.06.2014 17:52:18.918InformationMessage status set to DLNG
09.06.2014 17:52:18.961InformationTrying to put the message into the send queue
09.06.2014 17:52:19.001InformationMessage successfully put into the queue
09.06.2014 17:52:19.001InformationThe message was successfully retrieved from the send queue
09.06.2014 17:52:19.006ErrorMP: exception caught with message No configuration / default adapter specified for EDISeparator
09.06.2014 17:52:19.006InformationDelivering to channel: B2BSE00002_O2C_ORDERS_VANS_PO_WRITE_EDISeparator
09.06.2014 17:52:19.006InformationMessage status set to DLNG
09.06.2014 17:52:19.009ErrorException caught by adapter framework: No configuration / default adapter specified for EDISeparator
09.06.2014 17:52:19.010ErrorTransmitting the message to endpoint <local> using connection AS2_http://sap.com/xi/XI/AS2 failed, due to: com.sap.engine.interfaces.messaging.api.exception.MessagingException: java.lang.Exception: No configuration / default adapter specified for EDISeparator
09.06.2014 17:52:19.015InformationThe asynchronous message was successfully scheduled to be delivered at Mon Jun 09 17:57:19 CEST 2014
09.06.2014 17:52:19.015InformationMessage status set to WAIT
Tags:
Former Member replied

Hi Saurabh,

Sorry for responding late. I was unwell.

Thanks @Dimitri Sannen for asking to share the scenario. I wanted to do the same.

@Saurabh: I request you to remove the EDIFACTConverterModule which you have put on the AS2Receiver Adapter.

It is first converting to XML and then trying to split which is wrong. After splitting it should convert to XML which you have already put after the EDI Separator Sender adapter.

Best Regards,

Ruchir

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question