Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

How do you disable "Use Collected Statistics" when triggering a BODS job using RUN_BATCH_JOB web service?

I am triggering a BODS jobs using RUN_BATCH_JOB, how do you disable "Use Collected Statistics" for the job?

The issue I am having is it keeps changing the CACHE TYPE to IN-MEMORY when the dataflow is set to PAGEABLE because of not being able to tell the triggered job to not use collected statistics.

RUN_BATCH_JOB input parameters are:

     - jobName, repoName, jobServer, serverGroup, globalVariables

     - jobParameters: job_system_profile, sampling_rate, auditing, recovery, job_server, trace[], distribution_level, substitutionParameters

     There is no parameters for telling the triggered job to "use collected statistics" or not.

What i've tried:

1. I've set the job properties->Execution Options->User collected statistics to unchecked as the new default

2. When I trigger a job manually in the Data Services Designer or the Data Services Management Console the default value for "use collected statistics" is unchecked. When the job runs it uses Cache Type PAGEABLE

3. When I trigger the job using the BODS web service RUN_BATCH_JOB it says it's switching Cache Type to IN-MEMORY which means the job is still defaulting to use collected statistics.

So how do use the RUN_BATCH_JOB web service and tell it not to use collected statistics?

We are using version 14.0.3.451

Rob O.

Tags:
Former Member
Not what you were looking for? View more on this topic or Ask a question