Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Unable to connect to OData service from Eclipse Juno + Kepler

Dear all,

I want to utilize the GWPA OData Toolkit for Java to consume an OData service running in NetWeaver Gateway in a Java application. When I try to install GWPA in Eclipse Juno via "Install new software", I can select the required components, confirm the License agreement, press Finish and... get the error below:

Almost all of the missing bundles belong to SAP - how comes? The Proxy settings are okay, as I can load https://tools.hana.ondemand.com/juno in the Available Software Sites preferences (same for Eclipse Juno site). At the first trial I received and error about missing components org.eclipse.emf.transaction... - I got over that by installing Eclipse EMF plugins from the respective download location via Install new software.

As an alternative I tried Eclipse Kepler (I know it is not officially supported for GWPA). Here the installation is successful, but when I try to generate a proxy class for an OData service, I can not enter credentials for basic authentication anywhere, there is no dialog comming up. Consequently, I get an error:

I tried to hand over credentials within the URL as http://<user>:<password@<server>..., but that does not work. We havenĀ“t prepared SSL access to the Gateway, as external access is only done via an SMP server so far.

Does anybody of you have clue how I could solve this?

Thanks a lot,

Ringo

Tags:
Former Member
replied

Hi Ringo,

a workaround, in case you cannot access the service URL, is always:

invoke the service in a browser and download the xml to a file on your local file system.

Do the same for the metadata document.

Then choose "File System" instead of "Remote Location" in the wizard that is displayed in the above screenshot.

Use the downloaded xml documents for generating the "Starter Application" or "Service Proxy".

This works and since the files are copied into the generated application, it doesn't have any side-effect.

Kind Regards,

Carlos

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question