Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Information Steward 4.2.1 not installing Data Cleansing Advisor (DCA) database

Our situation is as follows:

We have a SAP BusinessObjects BI 4.1 Sp3 system on Windows Server 2012.

We are installing the following components onto a separate, new Microsoft Windows Server 2012 platform (in this order):

- Information Platform Services (IPS) 4.1 Sp3

- Data Services 4.2 Sp1 Patch 3

- BusinessObjects BI 4.1 Sp3 Client Tools (for the BOE Metadata Integrator)

- Information Steward  4.2 Sp1 Patch 3

We verified the cross compatibility between IPS, DS and IS with SAP Note 1740516.

SAP Note 1740516, as referenced in the PAM, lists the following: "BI 4.1 SP3 was officially certified with DS/IS 4.2 SP1 Patch 3".

Our repository databases are located onto a separate Microsoft SQL Server 2008 Enterprise instance and the domain "DS/IS" service account under which IPS, DS and IS are installed, and will operate the Tomcat, DS and SIA services, has full access to these databases.

All required repository databases, including the IS repository, were created at forehand.

IPS and Data Services install fine without any problems. IS also installs fine, without the "Addnode" or Metadata Integrator installation issues that I have seen with previous versions. There were no errors of any kind.

The "Information Steward" and "Data Services" nodes are available in the IPS CMC and can be accessed.

However - the EIM APS is shown as "Running with errors"!

Trouble shooting the EIM APS reveals that the Data Cleansing Advisor (DCA) Service is the culprit.

Selecting the properties of the EIM APS also shows that the DCA Service could not be started and is marked in red. All other entries seem fine.

Once the DCA Server is removed from the EIM APS, the EIM APS will return to a green "Running" status.

This seems to indicate that the DCA Service is faulty. Checking the ..\BusinessObjects Enterprise XI 4.0\Data\DCA-SA\Data directory shows further evidence of this issue, as this directory is EMTPY. The expected DCA database file and the DCA log files are not there!

We have tried a number of things:

1. Removing the DCA service from the EIM APS, restarting the SIA/IPS, adding the DCA service to the EIM APS again.

2. Uninstalling IS 4.2 Sp1 Patch 3, rebooting the server and repeating the installation again.

2. Uninstalling IS 4.2 Sp1 Patch 3, rebooting the server and repeating the installation with IS 4.2 Sp1 Patch 0 (GA release)

3. Upgrading the IS 4.2 Sp1 Patch 0 (GA release) with the IS 4.2 Sp1 Patch 3 version.

None of these have made any difference whatsoever.

I have found 1 post on SCN with the exact same problem:  http://scn.sap.com/thread/3475164

Unfortunately, the listed solution of reinstalling has clearly not worked for us.

Has anybody seen this problem before? Any ideas what else we can do to resolve this issue? Our next port of call is opening a SAP support call but we really want to get IS up and running ASAP  - so any suggestions would be most welcome!

Tags:
Former Member
Former Member replied

Hi Erik and James,

This has been fixed in 4.2 SP2 and will be fixed in an upcoming patch for 4.2 SP 1, as well.

Below are steps you can take to work around the issue you are seeing:

1. Copy the files that are in <Install Directory>\InstallCache\im.lac.icc.cdq.cognitivedq.pjs.services.backend-4.0-core-nu\14.2.1.<your build number>\actions\plugins\14.1.2

         

To

<Install Directory>\SAP BusinessObjects\SAP BusinessObjects Enterprise XI 4.0\java\pjs\services\ICC.DCAService\lib

2. Restart the EIMAdaptiveProcessingServer.

Thank you,

Lynne

3 View this answer in context
Not what you were looking for? View more on this topic or Ask a question