Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

0509-150 Dependent module libclntsh.a(shr.o) could not be loaded after kernel upgarde

Hello Expert,

Recently we updated our kernel to 720_EXT of patch 500. After upgrade we found that from DB13 no jobs are running and giving error as below:

Job started

Step 001 started (program RSDBAJOB, variant &0000000000208, user ID )

Execute logical command BRCONNECT On host

Parameters: -jid STATS20140220090543 -u / -c -f stats -t ALL

exec(): 0509-036 Cannot load program brconnect because of the following errors:

0509-150   Dependent module libclntsh.a(shr.o) could not be loaded.

0509-022 Cannot load module libclntsh.a(shr.o).

0509-026 System error: A file or directory in the path name does not exist.

External program terminated with exit code 255

BRCONNECT returned error status E

Job finished

Previously every thing was working perfect.

We are using ERP 6.0 EHP5, ORACLE 11.2, oracle client 11.2 and AIX 6.1

Kindly suggest.

Regards,

Tarun

Former Member
Former Member replied

Dear All,

Thanks for all you support. Problem has been solved.

Problem was we had installed oracle client 11.2 at path of /oracle/client/10x_64.

So if we installed  new kernel (in our case 720_ext) 11.2 client must be at path of /oracle/client/11x_64.

This is hard coded.

I again installed same client at path 11x_64 and problem solved.

Tarun

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question