Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Afaria 7 SP4 iOS Enrollment problem

Hello,

I have an issue after upgrading Afaria to SP4: When I navigate to the EUSSP and click on enroll i receive a HTTP 404 on the following url:

http://server/aipsR/Register?ID=<deviceId>&ClientType=-8

Seems that in the aipsR folder the Register.aspx file doesn't exists....

I've done a reinstall of the enrollment server, but still this file doesn't exist.

Anyone has an idea what the possible root cause is and maybe have a solution for this issue?

Enrolling via the workaround with accessing the ssp on a desktop still works.

Thanks in advance!

Robin

BTW: we do not use a relay server in this (demo) installation.

Tags:
replied

Robin,

I hope you were able to resolve this issue.

In SP4, MDM-first enrollment was introduced, and with it, a network "hop". A connection would be made to the /aipsR/ application, and then, in order to communicate with the /aips2/ application, a call would be made to the server address from the Device Communication page. This is typically a load balancer, firewall or Relay Server, and the address is to the EXTERNAL network address. Most networks will not allow connects from within the firewall to access external addresses.

I believe that this behavior was removed in SP5.

In the meantime, if you can't arrange to allow your enrollment server to access the external server address, the most common solution is to add an entry to the hosts file on the enrollment server, so that the external address is routed to the internal address of the same server.

I hope this helps,

Mike Loop - SAP Active Global Support

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question