Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAP HANA Studio won't load after software installation failure

Hi,

I've been trying to follow the End to End Development Example for ABAP with HANA at End to End Development Example with SAP NetWeaver 7.4 & SAP HANA

However I have now come to a dead-end as my HANA studio won't load after trying to install the required plug-ins for the SAP Gateway Product Accelerator and the UI Development Toolkit for HTML5 (I already had the ABAP Development tools successfully installed).  When I installed these from https://tools.hana.ondemand.com/juno I got messages about registry errors and when I tried to exit it just got into a loop repeating the error messages.  I eventually had to cancel the application using Task Manager.

Since this error I am unable to load the HANA studio.  When I open it it starts to load - I see messages such as Loading Workbench, and I see very fast message mentioning eclipse (which is so fast I can't read it), but then it just closes down.

I have tried:

Uninstalling & re-installing the studio - the re-installation seems to be successful (clean log, no error messages), but no joy

Uninstalling & re-installing the studio and hana client- no joy

Doing a Windows system restore to about one week prior to this installation - no joy

Doing a system restore with uninstall and re-install- no joy

Prior to this I had a working version of the studio with which I could access my HANA on AWS and was able to browse around the abap development objects and the HANA database procedures etc.  But the End to End Development Example mentioned that these extra plug-ins were required so I tried installing them.

I am on Windows 7 and the HANA studio and client I was using were Win 64 Rev 68.

Also I had been advised NOT to install my HANA studio in C:\Program Files, so it was installed in a folder C:\SAP\hdbstudio

I am stumped at the moment, so would really appreciate some advice on how to move forward.

Thanks

Andy

Former Member
Former Member replied

Hi Andy,

It could be a workspace issue or parameter issue in hdbstudio.ini file :

Could you please check the following:

Studio.ini issue 

goto HANA Studio installation location-> edit hdbstudio.ini file.Set parameter

       -Xmx1024m to -Xmx512m

          Try opening HANA Studio if it still doesn't opens, change second parameter:

-XX:MaxPermSize=1024m to -XX:MaxPermSize=512m

  Workspace issue

       If studio is installed in folder C:\Studio_SP6\

Create a directory C:\My_workspace

To launch HANA studio give C:\Studio_SP6\hdbstudio.exe -data "C:\My_workspace"

Best Regards,

Sharada

Please refer below link for additional details:

http://scn.sap.com/community/hana-in-memory/blog/2013/07/16/hana-studio-launching-issue-all-errors-and-solution

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question