Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

No any Diagnostic Agents in step 5.6 (Solman_setup, SM7.1)

Good day, respected experts.

I try to complete our solman_setup.

There I have a problem at "System Preparation->Step 5.6 Connect Diagnostic Agents".

I click on "get agents" and I no any  agent in list: "Agents available in all SLD: The table does not contain any data"

What parameters or settings I might have overlooked, and how you can determine what the problem is?

Former Member
Former Member replied

The problem was solved. Here are the steps I have taken ( only describing their way , maybe others will be others): the point 1 (with logs) - is very helpfull, and my recommendations - see the logs primarily
1. Using the Diagnostic Agent logs to determine the detailed problem
DAA agent logs /usr/sap/DAA/SMDAnn/SMDAgent/log
2 .Use note 1900072 - helps identify areas and ports of entry and connection agent
3 .Using note 1822831 - helps determine the overall connection error .

4. Using notes 1829601  - Connect Diagnostics Agent into the Solution  Manager step in SOLMAN_SETUP (System Preparation) does not show any agents available in the SLD - Use the utility /usr/sap/SMD/DAA/<agent ID>/script/smdsetup.sh
5 . Check for user SMD_ADMIN and reinstall it a password. Required to follow the initial authorization of any agent
so it makes sense to look at these threads are here
http://scn.sap.com/thread/613169
http://scn.sap.com/thread/3448611
http://scn.sap.com/thread/3362571


I did exactly that :
1. defined ports to interconnect the P4 ( see note 1900072 )
2 . Used utility smdsetup.sh managingconf hostname: sslm.inlinegr.com port: 50004 user: SMD_ADMIN pwd: ...
3 . Restart the virtual machine

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question