Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

TEXTENV_KEY_INVALID on SAP GUI logon at import phase 24

Dear all,

   

I have succesfully done the OS migration for all systems in the SAP landscape (DEV, QUA and PROD). Source system is HP-UX 11.31 , Oracle
11.2.0.3 and ECC 6.0. Target system is RedHat 6.4 , Oracle 11.2.0.3 and ECC 6.0.

For the first migration test I used the SWPM tool version SP02_1.

    

Due to some additional developments needed for the ongoing projects, I need to re-import the  DEV and QUA systems to include the latest SAP customizations.

I did export of DEV system and deleted the file system data
in the target for DEV :

  - /oracle/DEV/sapdata1-6

  - /oracle/DEV/mirrlogA,B

- /oracle/DEV/origlogA,B

- /oracle/DEV/saparch

 

And then started the import.

 

On the phase 24 Check DDIC password I've got the information message :

  " Test logon to SAP system DEV failed.

  SOLUTION: Make sure that the system is started, that the
user DDIC exists and that the password of user DDIC is correct.”

    

For the second migration test, now I used the SWPM tool version SP03_1.

I tried the SAP GUI and get the message “ Invalld key when accessing SAP text environment table TCP0C.”

In the dev_w* logs also there are error messages TEXTENV_KEY_INVALID  and A Invalld key when accessing SAP text environment table TCP0C

From the SAP note 375182 even it’s not appropriate for my case I tried :

 

  1. Stop SAP
    instance
  2. Edit the
    instance profile in /usr/sap/<SID>/SYS/profile by adding the following
    two lines:

       a) abap/set_text_env_at_new_mode = 0

       b) install/collate/active = 0

3. startsap

The error messages still appeared.

Do you know how to solve the error and to finish the installation on taget for import.

I have already prepared all LINUX locales for the previos OS migration ana I don't know what should be the problem now because the TCP0C missing entries in the first migration test I solved after starting the instance . Now I cannot connect with SAP GUI due to this error message.

Thank you in advance.

 

Best regards,

Ruzica

Former Member
replied

Hi,

Please set these parameters and try.

abap/set_textenv/ignore_errors = 1

abap/set_textenv/skip_all = 1

If it helps, these parameter you must removed later, once your import is completed.

Also at last  you will have to look in to the contents of TCP0C table for insertion of missing records, for this OSS message will help you.

Cheers !!!

Ashish

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question