Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Server configuration file for SAP GUI 7.30 doesn't work on Citrix XenApp

Hi all

We upgraded from SAP GUI 7.20 to SAP GUI 7.30 and within this upgrade we also upgraded our ctrix server farm. Unfortunately when a user opens SAP Logon within XenApp, the following error occurs:

"I'll try to translate: SAP Logon could not be started correctly.

Error while loading local configuration files:
Name of tree structure file http://<server>/SapLogonTree.xml invalid."

The server configuration file works well on normal clients. Also the file works well if I log in via administration console on the citrix server. I deleted registry entry HKLM\SOFTWARE\Wow6432Node\SAP\SAPLogon\Options\ConfigFileOnServer (was set with installation/upgrade from installation server) and HKLM\SOFTWARE\Wow6432Node\SAP\SAP Shared\SAPsourcedir but still the error occurs.

I also tried to put a local saplogon.ini in C:\Users\Default User\AppData\Roaming\SAP\Common but it doesn't work either.

Does anyone have a hint to solve this problem? Any help will be appreciated.

Kind regards

Jann

Former Member
Former Member replied

The issue is resolved.

The fault was, that the call of the saplogon.exe in the Citrix Admin Console was set to "C:\<path>\saplogon.exe /ini_file="http://<server>\SapLogonTree.xml" instead of the .ini file.

Thank you anyway.

Jann

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question