Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Solution Manager 7.1 installation failing

Hello,

I am trying to install Solution Manager 7.1 on Oracle 10.2 and Linux. Unfortunately, at the very beginning of the installation, I am getting

a very bizzare error, during creating the users for the SAP system, here is an excerpt from my sapinst.log file:

TRACE  2013-08-05 20:47:30.334 [syuxctask.cpp:880]
       CUnixProcessManager::sap_waitpid(pid_t pid, int * pStatus, int options)
       lib=syslib module=syslib

Child process 5284 returned 0

ERROR  2013-08-05 20:47:30.355 [sixxcstepexecute.cpp:916]

FCO-00011  The step setUserEnvironment with step key |NW_Users_Create|ind|ind|ind|ind|0|0|NW_Users_Create_Do|ind|ind|ind|ind|usersCreateDo|0|setUserEnvironme

nt was executed with status ERROR ( Last error reported by the step: Assertion failed: in

function (role, readAccountData) {

if (readAccountData === undefined) {
    readAccountData = true;
}
NWUsers.trace("NWUsers.getAccountData(", role, ")");
this._initAccountData();
ASSERT(arguments.callee, this.haveAccountData(role), "role " + role + " is not created yet.");
var ad = this._readAccountDataFromKeydb(role);
if (readAccountData) {
    ad = this._readAccountData(ad);
}
var masterpwd = this.getMasterPassword();
if (ad.password == "" && this._useMasterPasswordForAccountData(ad) && ad.type == "USER" && masterpwd !== undefined && role != NWUsers.roles.J2EEGuest &&

!ad.locked) {

    ad.password = masterpwd;
}
NWUsers.trace("NWUsers.getAccountData(): ", dump_properties(ad));
return ad;

}

role ORA_SID is not created yet.).

TRACE  2013-08-05 20:47:30.380 [kdxxctaco.cpp:165]
       CKdbTableContainerImpl::syncToContainerFile lib=iakdblib

CKdbTableContainerImpl::syncToContainerFile start ...

TRACE  2013-08-05 20:47:30.420 [kdxxctaco.cpp:197]
       CKdbTableContainerImpl::syncToContainerFile lib=iakdblib

after creating out stream

I've tried to google, but no help, Note 972263 - Inst.NW 7.0(2004s)SR2/Business Suite 2005 SR2-UNIX/Oracle is not helpful either.

I've tried to run solely the preparation option for user creation. No luck :-/

I am  installing using the latest version of the SWPM, so I guess this shouldn't be some JVM issue... PLEASE HELP !!!

Tags:
replied

Thanks, I'll have a look on it, as soon as I'll have time.

Installation on DB2 worked fine...

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question