Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem during install DB Studio on Linux

Dear community,

i need to install the Database Studio on the same server our MaxDB is runnig, its a Linux SUSE Enterprise 11 (64-Bit).

I downloaded the DB Stuio, extracted it on my server, after that I tried to install it with ./SDBSETUP

then the following error occurs:

"cannot load wxWidgets properly: Can't load './Wx.so' for module Wx: libpng.so.3: cannot open shared object file: no such file or directory at DynaLoader.pm line 230.

at SDB::Common::Require line 61"

I've searched the version of libpng I have, it's the libpng12, so i tried to install libpng3 but this doesn't work beacause libpng12 is allready installed, but i can't unistall it because it's needed for some application.

Can somebody please help me? This freaks me out I don't know what to do

greetings

Christina

Tags:
Former Member
replied

Hello Christina,

using ./SDBSETUP I get the same error message on openSuse 11.4 (64bit). But using ./SDBINST (no GUI) instead ist working fine, also for updates!

DB Studio Version: 7.9.08.01 / 7.9.08.05

Regards,

Thomas

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question