Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

"Unable to launch application" when starting IB / ESR on PI 7.11

Hello,

I have found some similar threads on this topic, but none that answers my question directly and none that solved my issue. So I am trying with a separate thread and hopefully somebody can help me.

We have PI 7.11 installed and I am trying to open (for example) the Integration Builder. Here I get an error message which does not really say much:

"Unable to launch the application". When I click "Details" I see this:

------

InvalidArgumentException[ Invalid arguments supplied: { }]

          at com.sun.javaws.Main.continueInSecureThread(Unknown Source)

          at com.sun.javaws.Main.access$000(Unknown Source)

          at com.sun.javaws.Main$1.run(Unknown Source)

          at java.lang.Thread.run(Unknown Source)

-------

This happens on our new Citrix environment which is built on XenApp 6.5 and runs Windows 2008 x64. It also runs IE 32-bits / Java 1.7.0_11 32-bits.

We do not have this problem in our old Citrix environment - here we are running Java 1.5.0_22. We tried downgrading Java on the new Citrix environment to also be 1.5.0_22 - and this worked. This is however the very last resort for us.

On my local computer (no Citrix) the Integration Builder starts just fine - here I am running Windows 7 32-bit and Java 1.7.0_11 32-bit.

I found this article (http://wiki.sdn.sap.com/wiki/display/XI/Troubleshooting+PI+ESR+and+Integration+Builder+Logon+Issues) and here it says that Java 1.7 should be supported - but only the 32 bits. So maybe it could be that since we are running 64-bits OS on the Citrix server the Java has got some problems to start properly - even if Java itself is 32-bits...

Has anyone here had a similar problem? I hope so.. and also that you found a solution :-)

Regards,

Tom

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question