Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

system copy crm 7.01 - r3load -testconnect fails

Hey together,

i like to make a system copy, with crm 7.01 (kernel 7.21 UC64)  on a windows sv 2003 r2 with sql 2005.

my problem is on "Export ABAP" step "testing database connection"

r3load -testconnect exists with error code 2

if i try via comand line 

r3load -testcibbect

(DB) ERROR: db_connect rc = 256

DbSlErrorMsg rc = 99

r3trans -d

2EETW169 no connect possbile "DBMS = MSSQL --- SERVER = 'MSSQLSERVER' DBNAME ='<sid>'"

no more information in the logs..

following environment settings

dbms_type = mss

MSSQL_DBNAME = <sid>

MSSQL_SCHEMA = dbo

MSSQL_SERVER = MSSQLSERVER

i have no clue i read much notes and forum entries but there is no solution.. pls help me

replied

Hello Steffen,

Checking the trans.log we can see:

4 ETW000  [     dev trc,00000]  ERROR: -1 in function SQLConnectWithRetry (SQLConnectWithRetry) [line 2373]

4 ETW000                                                                                                  36  17.014197

4 ETW000  [     dev trc,00000]  (11001) [08001] [Microsoft][SQL Native Client]TCP Provider: Der angegebene Host ist unbekannt.

And from your description:

following environment settings

dbms_type = mss

MSSQL_DBNAME = <sid>

MSSQL_SCHEMA = dbo

MSSQL_SERVER = MSSQLSERVER

For the 7.01 systems I would expect something like:

dbms_type = mss

MSSQL_DBNAME = <SID>

MSSQL_SCHEMA = <sid>

MSSQL_SERVER = <sql_instance>

The <sql_instance> can be:

  1. <machine_name> = default instance
  2. <machine_name>\<instance_name> = named instance

So, my first suggestion is to check the environment variables.

Regards,

Eduardo Rezende

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question