Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error has occurred while attempting to load the Crystal Reports runtim

Hi all,

I'm using VS 2008 to create a business app that uses Crystal Reports to display and print reports. I'm distributing it mostly to Win7 Pro 64 bit machines.

The program is working on ALMOST every machine, but I just installed it on a new laptop, and whenever I access the Crystal part of the program, I get the classic "Either The Crystal Reports registry key permissions are insufficient or the Crystal Reports runtime is not installed correctly".

Googling this error, the UNIVERSAL answer is "Target your VB application at x86 only." The problem is, I ALREADY DID THAT. And this program works on all my OTHER Win7 64 bit machines. It's just this one.

Can anyone help? I'm at my wits end. I've tried installing, uninstalling, installing while right-clicking and choosing Run as Admin...

Thanks,

Andy Oliner

Tags:
Former Member
Former Member replied

Okay, I found the problem. For whatever reason, Crystal requires BOTH the x86 and x64 runtimes installed. The installer program seems to try to install both, but is only successful in installing the x64 runtime. When I copied over the x86 runtime and installed it manually, that solved all of my problems.

Thank you for your brief attempt to help me, however useless it was. I am disappointed that SAP does so little to help their customers, and that the SAP website is so incredibly difficult to navigate and use. I will certainly keep all of these factors in mind as I make purchase decisions in the future.

2 View this answer in context
Not what you were looking for? View more on this topic or Ask a question