Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

issues in sldcheck and sldapicust

Hi All,

I am unable to launch the nwa or j2ee start page when i give sldcheck in new PI7.3(abap+java) system  .Below are the errors.I have tried with users sldapiuser and slddsuser,piappluser.It is not working fine.I have assigned the necessary role to piappluser,slddsuser and sldapiuser.But still facing issues when i give sldcheck and sldapicust too.

SLDCONNECTION TEST via SLDAPICUST

SLD Connection Test

Communication mode: RFC + HTTP (deprecated)

Properties of RFC destination SAPSLDAPI

  RFC host:        %%RFCSERVER%%

  Program ID:      SAPSLDAPI_PIR

  Gateway host:    **********

  Gateway service: sapgw00

Testing RFC connection to the SLD java client...

RFC ping was successful

SLD destination settings:

  Alias:       SAP_CONFIG

  Host name:   *************

  Port number: 50000

  User:        sldapicust

Testing HTTP connection to the SLD server...

An exception has occurred:

Exception in SLD client: AbapSLDRequestHandler.ping(): CIM_ERR_FAILED: User credentials are invalid or user is denied acces

#############################################################################################################

SLDCHECK::

Exchange Infrastructure: Test LCR Connection

Communication mode: RFC + HTTP (deprecated)

Properties of RFC destination SAPSLDAPI

  RFC host:

%%RFCSERVER%%

  program id:      SAPSLDAPI_PIR

  gateway host:      ******

  gateway service: sapgw00

Testing the RFC connection to the SLD java client...

RFC ping was successful

SLD destination settings:

  Alias:       SAP_CONFIG

  Host name:   *******

  Port number: 50000

  User:        sldapicust

Use transaction SLDAPICUST if you wish to maintain the SLD server access data

Launching the SLD GUI in a separate browser window...

=> Verify in the browser GUI that the SLD is in a healthy running state!

Calling function LCR_LIST_BUSINESS_SYSTEMS

Retrieving data from the SLD server...

Function call returned exception code     4

=> Check whether the SLD is running!

Summary: Connection to SLD does not work

=> Check SLD function and configurations

Regards

basis

Former Member
Former Member replied

Hi Ram,

You need to maintain the host file entry in your system as well.

On your system where you are opening the sapgui.

goto start of your window system -> click on run--> in run type drivers-->goto etc and open the host file out there and enter the entry out there. It will work

Moreever if you are using the IE 9 then change it to IE7 or IE8

Open the internet explorer-->goto tools--> over there look for developer tool --> over there you will get option to change it.

If not get successfull,

you can do it :

http://<ip_address_of_sld>:<portnumber>/sld

Grant a point if helpful.

With Regards

Ashutosh Chaturvedi

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question