Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

MaxDB not running

Hi,

We just installed a new MaxDB(7.9.08.01) on a linux machine. We wanted to use the tool SAP MaxDB Database Studio to manage our databases. However, we cannot create a new database: It says "-813 Cannot connect to host localhost:7210[Connection refused], -813."

And then we tried dbmcli(Database Manager CLI). However, we cannot do anything with any database although we can create. When we run the command db_state, it outputs :

"

OK

State

Offline

"

db_connect:

"

-24936, ERR_DBNORUN: Database instance is not running

"

db_online:

"

ERR

19, Error while using the file ID 'RunDirectory'.

-24979, ERR_XPNOTFOUND:Parameter RunDirectoryPath not found

-24748, ERR_FILEOPEN: Error opening file MAXDB50

"   (maxdb50 is the db instance)

Any help is high appreciated,

Thank you very much in advance,

Best regards

Tags:
Former Member
Former Member replied

Hello,

The error: 813 Cannot connect to host localhost:7210[Connection refused], -813."

Before you add the server to the Database Studio to manage, you need to make sure that the x_server and the globallistener are started.

Run the following command as administrator and let me know the ouput- Comand:  "sdbregview -l"

Run the dbmcli commands as a user in the sdb group or the root/administrator user - because other users will not have access to the Database Runtime folders.

Adjust the database instance parameter RunDirectoryPath. You must adjust the value of the parameter RunDirectoryPath accordingly. You can convert the parameter using the following command:

dbmcli -d <SID> -u control,<passwd> param_put RunDirectoryPath
/sapdb/<SID>/data/wrk/<SID>

Best Regards,

Yashwanth

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question