Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

PI Instance could not start after Kernel upgrade from 7.11 to 7.20

Hello, Experts,

I'm now upgrading SAP kernel from 7.11 to 7.20 with PI.

Referring to SAP Note:1636252

The steps are...

1.Download kernel files SAPEXE_201, SAPEXEDB_201,DBATL720O10

2.Backup old kernel files.

3.Change access permission of old  kernel executables

4.Delete old  kernel executables

5.Extract new kernel files with SAPCAR.

6.Execute root.sh

7.Execute sapcpe to copy new kernel files.

8.brconnect -u system/<pw> -f chpass -p <new_password>

After step 8, PI Instance won't come up with error message below.

-----------------------------------------

Starting Startup Agent sapstartsrv

Unknown webmethod: WaitforServiceStarted

Startup of Instance Service failed

See /home/dt0adm/startsap_SCS01.log for details

-----------------------------------------

At first I tried to start PI instance after step7,

PI instance won't come up.

So I checked some note and SCN Discussion.

I concluded this situation will be solved with step 8, But it still won't work.

Does anyone have faced similar situation like us ?

If you have any ideas about this condition?

Please let me know.

Our environement is below.

OS : RedHatEnterpriseLinux 5.8

DB : Oracle11.2.0

Componet: PI7.1Ehp1 SP08

Best Regards,

Former Member
Former Member replied

Dear  M. Dijsselbloem.

Thanks for your advice.

I appriciate your comment very much!

I checked all of procedure I have done.

I found that the Kernel files was for Non-Unicode system!!

I re-down load the Kernel files fo Unicode system.

After all I succeeded the Kernel upgrade.

The only change I have made from the instruction was execute sapcpe not only for DVEBMGS00 but also for SCS01.

Best Regards,

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question