Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error with HTTP destination when creating Endpoint with SOAMANAGER

   Hi,

   I'm consuming a WebService and the creation of the Proxy Class ('SE80') was OK. The issue appears with the Set Up of the Logical Port with transaction SOAMANAGER.

   I find my Proxy and generate the Logical Port using WSDL Based Configuration. When I save all, the message  " Binding 'dctmwsbeanSoapBinding' activated in service '0017A477000C1EE1AEC36DAD09868C00' " appears. It seems to be all right, but it doesn't.

   If I go to "Additional Information" tab, under the Logical Port created, I don't see the HTTP Destination... If I go to the 'SM59' transaction, there is not created the HTTP destination ('0017A477000C1EE1AEC36DAD09868C00'), that SOAMANAGER said it was created.

   It worked fine in Development and Quality Systems. After a change with an auth. certificate, the HTTP destinations disappeared. So I tried to delete and re-create the endpoints, but there aren't the HTTP destinations.

   I also tried to initializate the ICM ('SMICM') but it doesn't work.

   This is the error from the Runtime Trace in transaction 'SOAMANAGER':

Interface name:CO_WSSAPCONTROL_PORT_TYPE

Communication Pattern: Method:GetSystemInstanceList

   The complete trace is attached.

****** Additional info *****

   This error from 'SOAMANAGER' appears every hour. The creation of the Logical Port isn't the reason, but this error can be the reason of the issue. I'm looking for some info about "CO_WSSAPCONTROL_PORT_TYPE" but I don't get any results.

*****************************

   At the moment I try to execute the Consumer Proxy from 'SE80', these messages are shown:

- "SOAP:1.008 SRT: Couldn't create Object: ("ICF Error when creating HTTP client object by Config for URL "https:// -- WSDL url --": ARGUMENT NOT FOUND")"

- "Error when calling SOAP runtime functions: SRT: Couldn't create Object: ("ICF Error when...")"

   Waiting for some responses...

   Regards,

Sergio Vidaller

replied

   Hi Martin,

   The note opened to SAP gave me the solution. I think you should do the same, but you can try with this OSS note:

Note 1669829 - Unable to generate LP with X.509 client cert. without WSDL

   Regards,

Sergio Vidaller

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question