Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Unable to connect to the CMS system database "MyDBName". Reason: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database "CMS" requested by the login. The login failed.

Background:

In trying to fix US-CERT Vulnerability Note VU#989719 - SAP BusinessObjects Axis2 Default Admin Password I changed the default password in the axis2.xml file in 6 different locations and restarted the system. After restarting the system, I was unable to connect to Business View - I get "unable to logon: could not logon to server myhostname:6400,  or pull up the Axis Administrator interface http://myhostname:6405/dswsbobje/axis2-admin/login -it just times out. Before modifying the axis2.xml file, I made a copy and worked from the copy. After i discovered things weren't working, I promptly backed out my changes by reinstating the original files, but the same problem occurs. sia.exe is running, but not cms.exe. I'm currently trying to get our Support information from our VAR and therefore cannot approach SAP directly for support. I'm hoping to get this resolved tonight as we have a training session scheduled for tomorrow morning. Can someone tell me how to fix this?

Event Viewer:

The root server reported an error Initialization Failure. (Reason: BusinessObjects Enterprise CMS: Unable to connect to the CMS system database "MyDBName". Reason: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database "CMS" requested by the login. The login failed.BusinessObjects Enterprise CMS: Unable to connect to the CMS system database "MyDBName". Reason: [Microsoft][ODBC SQL Server Driver][SQL Server]Cannot open database "CMS" requested by the login. The login failed. CDatabase::Open failure.

).

Thanks in advance,

-Chauncey

Tags:
Not what you were looking for? View more on this topic or Ask a question