Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Explorer connecting with HANA using JDBC connection

Hi

May be its repeat of below post.

but i did not see the answer for Explorer and HANA native connection. so i am posting again.

Native JDBC connection from BO Explorer to HANA

I am trying to connect Explorer4.0 with HANA SP3 Database using JDBC native connection.

I am not using IDT and connection wizard settings.

1)Under connection serverjdbc directory which SBO file should i have to change?I am not working on Maxdb, why should i change maxdb.sbo file? should i have to use JDBC.sbo(Generic datasource) file?

I changed as follows in maxdb.sbo file too but connection (SAP HANA) 1.0" is not shown in "manage Source" of Explorer.

</DataBase>
	<DataBase Active="Yes" Name="SAP HANA database 1.0">
	  <Aliases>
        <Alias>SAP High-Performance Analytic Appliance (SAP HANA) 1.0</Alias>
      </Aliases>
      <JDBCDriver>
        <ClassPath>
            <Path>C:Program FilesSAPhdbclient
gdbc.jar</Path>
        </ClassPath>
        <Parameter Name="JDBC Class">com.sap.db.jdbc.Driver</Parameter>
        <Parameter Name="URL Format">jdbc:sap://$DATASOURCE$</Parameter>

2)Also I did below changes at CMC

-Right-click "Explorer", and select "Properties".

-Within "Advanced Configuration", set the following parameters, and save them.

newdb.system.alias = DBHANA
newdb.url = jdbc:sap://XXXXXX:30015
newdb.authentication.mode = ConfiguredIdentity    
newdb.user = system <Hana System userid>
newdb.password = xxxxxxxxx <Hana System password>
newdb.connections.enabled = true

※Why all files starting with newdb.xxx i dont understand. does the above setting is correct?

3)Return to CMC's home screen, and click "Users and Groups".

4)Click "User List", right-click on "Administrator", and select "Properties".

5)Check "Enable Database Credentials", and enter HANA database user id and Password(not an administrator password), and save them.

6)but "SAP High-Performance Analytic Appliance (SAP HANA) 1.0" is not shown in "Sources".

Ofcourse finally, restarted Explorer service to see the HANA connection but no use.

Pls advice.

Regards

magalingam

Former Member
replied

Hi,

Please follow the below procedure for the native HANA Connection in Explorer

1.Install HANA Client on BI 4.0 Server

2.Locate the JDBC driver

The default HANA client install folder locations (in Windows):

64-bit Client install: /program files/sap/hdbclient

32-bit Client install: /program files (x86)/sap/hdbclient

Locate the JDBC driver file: ngdbc.jar

3.Setting at BI4 connection server

Copy ngdbc.jar from previous step to:

BI4_INSTALL_PATH\SAP BusinessObjects Enterprise XI 4.0\dataAccess\connectionServer\jdbc\drivers\newdb

(create newdb folder if required)

Restart the BI4 Adaptive Processing Server in CMC

4.Setting at BI4 Explorer server

Stop Tomcat server where BI4 Explorer is deployed.

Copy the same ngdbc.jar and replace the jar in: BI4_INSTALL_PATH\Explorer14.0\plugins\com.sap.ngdbc_1.0.0\lib

Restart Tomcat server

Rgds,

Murali

1 View this answer in context
Not what you were looking for? View more on this topic or Ask a question