Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

WSDL missing <xsd:annotation> & <xsd:appinfo> tags for new field

Hello Experts,

I was recently asked to add a new field to a service interface. I made the changes to the Data Type and Mapping as appropriate and after activating those changes went to the Sender Agreement to save the WSDL in a file so I can handle it to our business partner (I created the file on the IB under Sender Agreement-->Display WSDL). When they uploaded the WSDL they could not see the new field. We checked the WSDL file and the new field is there but it's missing the <xsd:annotation> & <xsd:appinfo> tags (which all of the other fields have).

Here's an extract of how the WSDL looks, the new field is ACTIONCODE:

:

<xsd:element name="SHIPLINENO" type="xsd:string" minOccurs="0">

<xsd:annotation>

<xsd:appinfo source="http://sap.com/xi/TextID">

x123456789y123456789z123456789xx

</xsd:appinfo>

</xsd:annotation>

</xsd:element>

<xsd:element name="ACTIONCODE" type="xsd:string" minOccurs="0" />

<xsd:element name="BILLOFMATERIAL" minOccurs="0">

<xsd:annotation>

<xsd:appinfo source="http://sap.com/xi/TextID">

x123456789y123456789z123456789xx

</xsd:appinfo>

</xsd:annotation>

:

As you can see the annotation and appinfo tags are missing for the new field ACTIONCODE. I think this might be the reason why they don't see the new field when they upload the WSDL to their system. Is there something else I need to do for the WSDL to be generated correctly?

Thanks,

Carlos

Former Member
Not what you were looking for? View more on this topic or Ask a question