Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal Reports for Enterprise connection error to BI 4.0 Platform

Hi All

We are trying to connect Crystal Reports for Enterprise to our BI 4.0 Platform, however we are getting the following error: "Failed to establish a connection. The cause was: Cannot connect to SAP BusinessObjects Enterprise at this time. Please try again later".

System Information:

- SAP BI Platform 4.0 SP02 patch 6

- Windows Server 2008 R2 64bit

- Tomcat 6.0.24

We have also installed the following client software:

- SAP BI Platform Client Tools 4.0 SP02

- SAP Crystal Reports for Enterprise 4.0 SP02

- SAP BI Platform Client Tools 4.0 SP02 Patch 6

- SAP Crystal Reports for Enterprise 4.0 SP02 Patch 6

Our deployment of the BI Platform is a distributed system where

- Server 1 hosts the BI Platform Services and

- Server 2 hosts the web application server

We have reviewed the following OSS Notes below from SAP first to determine if there is a technical issue :

- 1598906 - Crystal Reports for Enterprise gives Cannot Connect to SAP Business Objects Enterprise at this time. Please try again later.

We have adjusted the "dsws.properties" as mentioned in the OSS note 1598906 above to contain the correct CMS and CMS port number (for Server 1).

- 1602024 - Error - Failed to establish a connection. The cause was - Cannot Connect to SAP BusinessObjects Enterprise at this time.

We have entered the server context as "/dswsbobje" mentioned in the OSS note 1602024 above in the connection details for CR for Enterprise connections

- 1636862 - Login for Crystal Reports fail on BO Server Cannot Connect to SAP Business Objects Enterprise at this time.

We have checked the proxy settings of Internet Explorer and adjusted it to have the following exceptions defined:

- Server 1.<domain_name>

- Server 2.<domain.name>

In the CMC, we also checked in the applications section for the web service option's access URL andchanged it from http://localhost:8080/dswsbobje to http://server2:8080/dswsbobje

We restarted the tomcat service and tried to access the CR for Enterprise from the BI Launch Pad as well as starting it directly from Windows, howevere we still get the same error.

Regards

Derek

Edited by: Derek Fox on Oct 27, 2011 1:07 PM

Edited by: Derek Fox on Oct 27, 2011 1:10 PM

Edited by: Derek Fox on Oct 27, 2011 1:11 PM

Edited by: Derek Fox on Oct 27, 2011 1:20 PM

Not what you were looking for? View more on this topic or Ask a question