Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

"SEND EMAIL" task error

Hi all,

I got an issue in "SEND EMAIL" task in workflow. The task is using standard BOR "SELFITEM", method "SENDTASKDESCRIPTION" to send the email.

First of all, the "SEND EMAIL" task work fine in Development system. After move the workflow into Quality system, the "SEND EMAIL" never work.

I had checked and done following:

- Email can be send via SBWP, and received in my outlook.

- Manually run the BOR "SELFITEM", method "SENDTASKDESCRIPTION" in SWO1, and email send successfully.

- Checked ST22 and there is no short dump.

- Check SU53 for user WF-BATCH, and didn't see any auth issue.

- Retransport the workflow definition from Development system into Quality system (3 times), but still not working.

- The email address is provided directly to the ADDRESSSTRING from workflow container, no user id is needed in this task. I check the workflow log, the ADDRESSTRING holding correct email address.

The SAP system is ECC 6.0.

The error that I got from the workflow log is "Exception 1001, Message area SO, Number 23 : Document <XXX> could not be sent". I had no clue at the moment how this can be happen.

Do anyone here got experience in this issue before?

Besides that, do anyone know how to debug the "SENDTASKDESCRIPTION" when the workflow trigger it? This is a background task, and the method is a standard SAP program, I can't write a long run loop in the code to hold it for debug.

Regards,

Edison Wang

Former Member

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question