Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

com.sapportals.portal.pcd.gl.PermissionControlException: Access denied

Hi guys,

Problem:

our basis team has recently swapped our JRE in our Development Portal with the oh-so-glorious SAP JVM4. Seeing the portal went completely haywire and nothing worked anymore, we've reverted back to JRE. Now there's a strange permission error persisting which I can't get rid of and don't understand what it's originating from.

The error occurs when I access any JAVA iView which has FPMs with a Test user having only Enduser permissions. With my Super-Admin user, it all works out. Here are the relevant snippets from the nwa error log (before this error, two more fatal errors are thrown which aren't shown in default trace they apparently cannot be handled; Message is "n/a"):

null 
[EXCEPTION]
 com.sap.xss.config.FPMConfigurationException: Read of object with ID portal_content/com.sap.pct/srvconfig/com.sap.pct.erp.srvconfig.ess.employee_self_service/com.sap.pct.erp.srvconfig.de/com.sap.pct.erp.srvconfig.bank/com.sap.pct.erp.srvconfig.fpmapplications/com.sap.pct.erp.srvconfig.per_bank_de failed.
	at com.sap.xss.config.pcd.PcdObjectBroker.retrieveObjectInternal(PcdObjectBroker.java:92)
	at com.sap.xss.config.pcd.PcdObjectBroker.retrieveObject(PcdObjectBroker.java:47)

	at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:104)
	at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:176)
Caused by: com.sapportals.portal.pcd.gl.PermissionControlException: Access denied (Object(s): portal_content/com.sap.pct/srvconfig/com.sap.pct.erp.srvconfig.ess.employee_self_service/com.sap.pct.erp.srvconfig.de/com.sap.pct.erp.srvconfig.bank/com.sap.pct.erp.srvconfig.fpmapplications/com.sap.pct.erp.srvconfig.per_bank_de)
	at com.sapportals.portal.pcd.gl.PcdFilterContext.filterLookup(PcdFilterContext.java:422)
	at com.sapportals.portal.pcd.gl.PcdProxyContext.basicContextLookup(PcdProxyContext.java:1248)
	at com.sapportals.portal.pcd.gl.PcdProxyContext.basicContextLookup(PcdProxyContext.java:1254)

System Information:

Backend: ECC 6.0 EHP 4 Stacks are on 8

Portal: Netweaver 7.01 Stacks are on 9 (this one missmatch isn't problematic and irrelevant here)

BPs:

sap.com BP_ERP5ASS 1.0 SP18

sap.com BP_ERP5COM 1.41 SP8

sap.com BP_ERP5ESS 1.41 SP9

sap.com BP_ERP5MSS 1.41 SP9

XSS JAVA COmponents:

sap.com SAP_ESS 603 SP8

sap.com SAP_MSS 600 SP19

sap.com SAPPCUI_GP 603 SP8

What I tried so far:

I've compared every known relevant setting as in Portal Roles, R3-Permissions, Portal Permissions on Objects, whether Services are active or corrupted in WebDynpro Administrator, Permissions on FPMs in SelfService-Admin. Everything is equal with our Quality Management System. And there, everything works fine with the exact same user...

It obviously has to do something with Portal Permission Control but as far as I am concerning, everything is maintained correctly and the settings have not been changed for ages....

I'm grateful for any help...

best regards, Lukas

Not what you were looking for? View more on this topic or Ask a question