CR for Eclipse 2.0 Install Error and Connection Problems

I'm using the Eclipse install manager to install CR for Eclipse 2.0, and am getting the error below:

Cannot complete the install because some dependencies are not satisfiable (2.0.11.r1346) cannot be installed in this environment because its filter is not applicable.

I recently installed Eclipse Indigo and am trying to get it to work with Crystal. I previously used an all-in-one version of Eclipse 3.5 that works fine.

I think I installed all the dependencis first by using the Indigo update site: Indigo - I installed the product packages:

-- Database Development (Data Tools)

-- Modeling (which includes EMF and GEF)

-- Web, XML, ... (which includes WST)

I am trying to install CR 2.0 from:

and that's when I get the error above.

As an alternative, I tried to install by droping the crystal jar files into my plugins folder, which sort of worked. Some of CR works fine, except the part about creating new reports or updating connection details of existing reports.

The real problem I have is that I don't have the option to use a POJO data source. When I edit the datasource for an existing report, I only have the option of using a connection under Data Source Explorer. In my old install, I could choose POJO from here.

Also, I don't have the option to create a new report from a Java class. I used to be able to right-click on the class and see a "Crystal Reports" submenu that let me "Add to a new Crystal Report." But that whole submenu doesn't appear for me.

If you can help with any of this, please let me know.


Edited by: Brandon Gallagher on Sep 4, 2011 10:50 PM