Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

PI 7.11 sp6 - SOAP error on INBOUND SYNC (BE) interface - No handler ...

Experts,

We're running a AIX 6.1 unix based PI 7.11 system patched to Stack SP6. We've got one instance...no web dispatcher or load balancing of any kind.

Our proxy system (sender) is an ECC6.0 EHP4 system. Our 3rd party system (receiver) system is non-sap.

In about a 2 hour timespan, we processed 9700 XML messages all in the SOAP adapter. almost all our traffic is BE (sync). Of those messages, we got 11 errors. And here is what we see in XSMB_MONI and in the java default trace:

#2.0^H#2011 08 29 15:40:08:183#0-500#Error#com.sap.aii.adapter.xi.ms.XIEventHandler#

#BC-XI-CON-AFW#com.sap.aii.af.lib#327C4279AB0F2E5C000000010019C0BE#3930552000000004#sap.com/com.sap.aii.af.ms.app#com.sap.aii.adapter.xi.ms.XIEventHandler.onRequest(Services, TransportMessage)#PIISUSER#8

546##875E5AD3D27311E0C8580000003BF9B8#875e5ad3d27311e0c8580000003bf9b8#875e5ad3d27311e0c8580000003bf9b8#0#Thread[HTTP Worker [@2008983637],5,Dedicated_Application_Thread]#Plain##

Message 4e5b07b7-8180-00ab-e100-80000ae201a4(INBOUND): was not delivered due to com.sap.engine.interfaces.messaging.api.exception.MessagingException: SOAP: response message contains an error XIAdapter/PA

RSING/ADAPTER.SOAP_EXCEPTION - soap fault: Server was unable to process request. ---> No handler is registered for this service.#

#2.0^H#2011 08 29 15:40:08:081#0-500#Error#com.sap.engine.messaging.impl.spi.ServicesImpl#

#BC-XI-CON-MSG#com.sap.aii.af.ms.svc#327C4279AB0F2E98000000000019C0BE#3930552000000004##com.sap.engine.messaging.impl.spi.ServicesImpl.deliver(Message)#J2EE_GUEST#0##875E5AD3D27311E0C8580000003BF9B8#875e

5ad3d27311e0c8580000003bf9b8#875e5ad3d27311e0c8580000003bf9b8#0#MS Queue Worker [SOAP_http://sap.com/xi/XI/SystemRqst]#Plain##

Caught exception com.sap.engine.interfaces.messaging.api.exception.MessagingException from application code with msgKey: 4e5b07b7-8180-00ab-e100-80000ae201a4(INBOUND)#

So I've looked all over the marketplace and SDN/google. I could not find anyone else getting this type of error.

We have WILY introscope and all the diag tools. I am not seeing any bottlenecks on the threads for http or inbound/outbound queues.

I was hoping someone could point me in the right direction. I was thinking about bumping up all the default queue threads for the com.sap.aii.af.ms.svc service. It has the default "10" for all those.

We have done MAJOR tuning already on this instance. I think I've read all the notes/guides/HOW-TO...etc that there is for PI 7.11. So we are making progress.

Thanks,

NICK

Former Member
Not what you were looking for? View more on this topic or Ask a question