Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Vertex RFC

Hi,

We have a thirdparty tax component Vertex integrated with our ECC. We did the system refresh recently and after that did the post-installtion steps for Vertex also. Somehow the Vertex RFC is showing the following error.

Logon Connection Error

Error Details Error when opening an RFC connection

Error Details ERROR: program VERTEX not registered

Error Details LOCATION: SAP-Gateway on host hollxd12.haworthinc.com / sapgw01

Error Details DETAIL: TP VERTEX not registered

Error Details COMPONENT: SAP-Gateway

Error Details COUNTER: 3082

Error Details MODULE: gwr3cpic.c

Error Details LINE: 1871

Error Details RETURN CODE: 679

Error Details SUBRC: 0

Error Details RELEASE: 700

Error Details TIME: Thu Jul 7 12:18:32 2011

Error Details VERSION: 2

I have tried to resgister the RFC using the command RFCEXEX -D<destination>. Nothing comes out. We are on AIX with Oracle.

Regards,

Krishna.

Edited by: Krishna Viswanatha on Jul 7, 2011 2:24 PM

Former Member
Former Member replied

Hi Krishna,

Please validate the following:

1) The tablespace for Vertex was properly exported/imported into the target system - post refresh.

2) You have checked and ensure that the sic-default.xml and r3-config.xml config files have the proper ID/Passwords for the relevant vertex users. TIP - you can test by logging into the vertex web service URL, an also the R3 user via logging into SAP system with user/pw.

3) Ensure the Vertex applications are running in Java VA tool.

4) This is the most important in regards to the RFC (I have seen same error if this has not been done): Make sure the SIC is started properly. Running this command on UNIX: Nohup run.sh & (from /usr/sap/SID/SIC/bin). Now, you may run this command and think all is well and good BUT - make SURE that BEFORE this command is run - you have the following env variable maintained for the SIDADM user: For LIBPATH variable you have: /usr/sap/<SID>/SIC/lib. That has been the culprit for me in many cases (the env variable missing before SIC start).

Hope this helps!

Let us know if your issue was resolved, and what the cause/solution was.

Thanks Sir!

T

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question