Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Survey Link sent out as an email (using Actions/No Campaigns) to Customer

Dear All

I need help with this scenario

We are using CRM 7.0.

From Leads we need to tigger an action to send out emails to the Prospects with a Survey Link.

They are out of network.

I apologize if I am asking this question again:

I went through the blogs from Greg, and also went through posts from Raja and Mike.

I was able to generate a Survey URL and we can also attach it to the email.

This is what I found and I am thinking of doing:

1. Create a Survey for Leads.

2. Set up the Internal ABAP CATServer using note 857535.

3. Implement the note 1542027 so that the check for connector ID is removed.

4. Import the parameter XML for http(s).

5. Generate the Survey URL

6. Set up the SAP Web Dispatcher to include a URL filter.

Q1. I am not able to understand, if we can use just a BSP paramter XML and Set up SAP Web Dispatcher for the survey to open up in external network. Do we really need the Internal ABAP CATServer to be set up. If Yes, what does it do? As I read and understood, the connector ID is not generated for Internal CATServer ABAP, and thats why we need to implement that note 1542027.

Q2. How do we pass the Customer ID to the parameter in URL? I see in generated URL, the appl_BUPA is not there. Will it require development? We are not using Campaign, as we need to send it out to each customer on status change.

Q3. Is there any different way to debug the genrated URL? I am not able to get into the debugging mode when I execute the Generated URL link from my internal netwrok. I am able to debug other BSPs and everything, but somehow for this the break point doesnt stop.

I tried external debugging and http debugging.

Please help!!

Thanks

Gaurav Sahai

Please advise if I need to do anything extra.

Tags:
Former Member
Not what you were looking for? View more on this topic or Ask a question