Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

rights from user NETWORK SERVICE Crystal Reports


I have a Windows Server 2003, IIS 6 with Crystal Reports Basic Runtime for Visual Studio 2008 installed.

The reports works fine, but my ​​security risk area has asked me to remove rights from user NETWORK SERVICE to C: \, if I try to run the report without rights, the following error occurs: "Load report failed", there is a workaround for this issue?

It was the permissions on "c:\". I added "network Service" to have read on this folder and the problem went away.

You can easily re-create this error by ensuring that the identity for the app pool in IIS has no permissions on this folder. As a result, crystal reports spews out the same error.

After enabling this I ran the ProcMon again but I can't see what CR is after. It just shows that it opens c:\ for read.

Since normally, and especially in the case of locked down servers, it is not very common to have "Network Service" or "Local Service" having any privileges on the root drive, I would like this to be treated as a defect and reported to the appropriate team.


Not what you were looking for? View more on this topic or Ask a question