Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SAP ECC 6.0 EHP5 migration from Oracle to SQL

Dear All,

I am stuck in between the migration process of ECC 6.0 EHP5 from Oracle 10.2.0.2 to MS SQL 2008.

Stuck at the ABAP import phase and asking for migration key...

" (VK) ERROR: invalid migration key"

Tried the Migration key provided in SAP Notes 970518 <REMOVED_BY_MODERATOR> Also generated the migration key from SAP market place.. still no success.

Checked the test_MIGKEY.log. Contents are below:

*****************************************************************************

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe: START OF LOG: 20110614140513

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe: sccsid @(#) $Id: //bas/720_REL/src/R3ld/R3load/R3ldmain.c#13 $ SAP

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe: version R7.20/V1.4 [UNICODE]

Compiled May 20 2011 23:28:40

patchinfo (patches.h): (0.088) DB2 z/OS: R3load does not recognize dbs_db2_sap_stosid (note 1583483)

process id 736

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe -dbcodepage 4103 -i test_MIGKEY.cmd -l test_MIGKEY.log -K 1G5fdEM50DmIrBzjt6TE5Pae

(DB) INFO: connected to DB

(GSI) INFO: dbname = "IN5KCSAP07 "

(GSI) INFO: vname = "MSSQL "

(GSI) INFO: hostname = "KCSAP07 "

(GSI) INFO: sysname = "Windows NT"

(GSI) INFO: nodename = "KCSAP07"

(GSI) INFO: release = "5.2"

(GSI) INFO: version = "3790 Service Pack 2"

(GSI) INFO: machine = "8x AMD64 Level 6 (Mod 26 Step 5)"

(VK) ERROR: invalid migration key

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe: job finished with 1 error(s)

D:\usr\sap\IN5\SYS\exe\uc\NTAMD64\R3load.exe: END OF LOG: 20110614140513

*******************************************************************************

Very strabge error : I am using WIndows OS and the R3load gives this error :- "DB2 z/OS: R3load does not recognize dbs_db2_sap_stosid (note 1583483)". The note says to use the patch 88 of R3load.

I have latest R3load version available on the market place for MS SQL.

R3load -v output is below:

********************************************************************************

C:\Documents and Settings\in5adm>R3load -v

sapparam: sapargv(argc, argv) has not been called!

sapparam(1c): No Profile used.

sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

-


R3load information

-


kernel release 720

kernel make variant 720_REL

DBMS client library

compiled on NT 5.2 3790 S x86 MS VC++ 14.00 for NTAMD64

compiled for 64 BIT

compilation mode UNICODE

compile time May 20 2011 19:59:34

update level 0

patch number 88

source id 0.090

-


supported environment

-


database (SAP, table SVERS) 700

710

701

702

703

711

720

730

731

operating system

Windows NT 5.0

Windows NT 5.1

Windows NT 5.2

Windows NT 6.0

Windows NT 6.1

*********************************************************************************************

R3trans -d also end s in an error:-

C:\Documents and Settings\in5adm>r3trans -d

This is r3trans version 6.22 (release 720 - 02.05.11 - 15:56:00).

unicode enabled version

2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

r3trans finished (0012).

*****************************************************************************************

ANy ideas on what cud be the issue..

Thanks

Sagar

Edited by: Juan Reyes on Jun 15, 2011 10:37 AM

Former Member
Not what you were looking for? View more on this topic or Ask a question