Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Aski user information while trying to print a report from a web application

Hi,

I am trying to print a report from web application. When I click on the print button then the page is redirected to the below link and asking for user information. See the below given link for more help.

_http://<server><port>PlatformServices/service/app/logon.do?appKind=InfoView&service=%2FOpenDocument%2FappService.do&backContext=%2FOpenDocument&backUrl=%2Fopendoc%2FopenDocument.jsp%3FSERVICE%3D%252FOpenDocument%252FappService.do%26OBJIDS%3D20016421%26backUrl%3D%252Fcontent%252Fview.do%26PREF%3DmaxOpageUt%253D200%253BmaxOpageC%253D10%253Btz%253DUS%252FPacific%253BmUnit%253Dinch%253BshowFilters%253Dtrue%253BsmtpFrom%253Dtrue%253BpromptForUnsavedData%253Dtrue%253B%26CONTAINERID%3D6424083%26backContext%3D%252FPlatformServices%26LOC%3Den%26APPKIND%3DInfoView%26PVL%3Den%26ACTID%3D280%26service%3Dtimeout&backUrlParents=1&appName=OpenDocument&prodName=BusinessObjects+Enterprise&cmsVisible=false&cms=<servername>%3A6600&authenticationVisible=false&authType=secEnterprise&sso=false&sm=true&smAuth=secLDAP&persistCookies=true&sessionCookie=true&useLogonToken=true

The instance Id for the report is generated successfully and the staus of the report is showing as success on Business Objects server side ie. crystal server side.

And we are using OpneDocumentURL for generating the report. And the in the URL we are passing the "Instatce ID" and the "Token" which Both are generated successfully.

Former Member
Not what you were looking for? View more on this topic or Ask a question