Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Problem while inserting data with more than 4000 character.

Hi All,

I am facing some issue while dealing with data having more than 4000 characters.

I am using SAP xMII 11.5.3 b66 and Oracle 10g. JDBC driver is u201Cojdbc14 10.2.0.5.0u201D. The datatype of column in the target table is u201CCLOBu201D (So it should accept data with more than 4000 characters).

Below given is the sample scenario I tried.

I have one table called u201CCLOBTABu201D and a column u201CCLOBCOLu201D with datatype CLOB.

I created a query template for inserting data into this sample table, u201Cinsert into CLOBTAB values (u2018[Param.1]u2019)u201D.

And I tried to pass the big data from front end through this u2018Param.1u2019. But it is throwing u201CERROR - java.sql.SQLException: ORA-01704: string literal too longu201D error.

Is there any work around available for this issue?

I checked the following threads, but not able to find a solution.

Oracle JDBC driver 10g and xMII: Oracle JDBC driver 10g and xMII

CLOB Data Columns: CLOB Data Columns

Do we need to set u201CSetBigStringTryClob=trueu201D for solving this? If yes, where to set?

Thanks is advance.

Regards,

Subin

Former Member
Former Member replied

Hi Subin,

As in 12.x you can upload the jdbc drivers, this will solve your problem.

Regards

Anshul

0 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question