Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

CR runtime for VS2010 (v13) not generating report

I installed Crystal Reports Runtime for VS2010 version 13 on Win2003 Server 64 bit (for intranet website that is used to execute reports). The web site is executed under Integrated security. The user account and the network service account have write and modify access to the designated temp folder on the web server. But for some reason when I execute the report, "Database Logon Failed" error is getting generated. Crystal Reports 10.5 runtime under same settings worked fine, but when I installed CR13 runtime and changed Web.config to point to CR13 version, it is generating this error. The correct version 13 is getting picked up as I checked the ReportDocument object's Class Version after the ReportDocument.Load() is executed, and it points to version 13. It is generating this error when executing " ReportDocument.ExportToDisk". Does any account other than the user account (logged in NT account) and service account require permissions to temp folder. Does any other folder require permissions? What is new in version 13 regarding the temp folder that CR uses to generate the report? The temp folder that is used in our intranet web site to generate CRs is a special folder (not C:\Win\Temp but another designated folder) that has the user account & Network service account have write and modify access. Has anything regarding the temp folder that CRs uses changed between CR10.5 and CR13. The web site, Crystal Reports(.rpt) and SQL server (Network is set up for Kerberos Authentication) are all set up for integrated security, and this set up worked with CR10.5 runtime, but does not work with CR13 runtime.

Error Details:

Server Error in '/' Application.

Database logon failed.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Database logon failed.

Not what you were looking for? View more on this topic or Ask a question