Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Exception before running Start routine


I am experiencing an issue in the Quality environment which does not happen in the Development environment.

When I run a DTP which loads data from an InfoObject's master data into another InfoObject's text table, a exception is thrown even before starting the execution of the start routine.

If I run it in debug mode, I notice that the exception is thrown at this sentence:

          CALL METHOD me->start_routine
              request        = l_request
              datapackid     = i_r_inbound->n_datapakid
              monitor        = _lt_msg_s
              SOURCE_PACKAGE = <_yt_SC_1>.

The exception reads "An exception (CX_SY_DYN_CALL_ILLEGAL_TYPE) occured".

I tried filtering the DTP in order to have only 1 or 3 records, but the exception still happens. It does not seem to be related to invalid data, since source data comes from an InfoObject -it is not raw data coming from a PSA table-, and filtering source records is not helping.

Have you experienced something similar?

Thanks in advance.

Best regards,




There are two solutions to this error:

1) Reactivate the affected transformation, and transport to your QA system.

2) Use the program RSDG_TRFN_ACTIVATE to reactivate the affected transformation. Make sure to set the object status to ACT.

Here is the OSS note documenting the program in solution #2:

Please note you need a certain patch level in order to use the program stated in #2.

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question