Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Error in DTP loading from 1st level DSO to 2nd level DSO

Hi Experts,

I am facing a strange kind of error while loading data through a DTP included in Process chain.

We are loading full load, from a DSO to a target DSO.

But it gives an error, "Error in substep : Start routine".

When i checked the error logs, it redirected me to the start routine, where a deletion statement is written.

We checked, with some ABAP persons, the code contained no error.

So we repeated the DTP(right click and repair), it worked fine this time.

There are several other DTP, with the same source and target.

As per the client requirement, we divided the loads and not loading at once.

The same error happened with other DTP also, but repeating them solved the problem again.

As this is only a work around, but it makes no sense as it had to be done manually everytime even though it is scheduled using a process chain.

Any one who has encountered similar problem, please share idea/information with me.





I had the same problem before, to debug the code, i put break point in the routine and couldnt find any error. Then loaded the data, it failed again. then I removed the break point from the transformation and activated it. When ever we activate transformation, a program is generated, if the program is not generated then this kind of problem occurs.



0 View this answer in context

Helpful Answer

Not what you were looking for? View more on this topic or Ask a question