Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

EMIGALL autogenerated Function Module missing

Hello,

I've been getting an error while migrating PART_REL standard MigObject...

error message:

Message no. EU086

"Function Module ZZKM1_EVNT_DLVE2_REP does not exist"

The function module really does not exist (checked with se37)...

I've also checked if the function module is ever called within the generated report for migrating the object, as well as if it used in the Events of the MigObject.

Does anyone have a solution for this problem?

Thank you.

Former Member
Former Member replied

Hi Igor

The problem is not within EMIGALL but within the Event Control of the Business Partner relationship.

Go to transaction BUBI,

Select Event 'DLVE2' and

Double-click Event->Function Modules in the tree on the left.

This should show you following entries:

100000 BUB_BUPR_EVENT_DLVE2 X BUB

200000 BUR_BUPR_EVENT_DLVE2 X BUR

...

You almost certainly find a row with ZZKM1_EVNT_DLVE2_REP in that list.

So either the function gets created / transported or you have to remove the row from the list.

The customising and the function module are not in the same transport (Workbench vs. Customising), which could be the reason for the mismatch. Or someone tested something without reverting the customising properly.

Yep

J├╝rgen

Edited by: sattlerj on Jun 10, 2011 4:56 PM

0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question