Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

SC Follow-on PO created but no link in SRM

Dear experts: we are facing a problem after SP upgrade to SAPKIBKV10. Let me try to explain:

We are working with SRM 7.0 system. Recently, our SRM installation has been upgraded to SRM_SERVER 700 level 10 (SAPKIBKV10) support package. Our backend ECC6 stills the same as before: SAP_APPL 604 level 7 (SAPKH60407). Our system type is ERP_4.0 and we have PI for backend integration (CPPR scenario is implemented and also we are using services).

Since the SRM upgrade was done, we are facing some new issues we hadn't before.

1.- When creating shoping carts resulting in a purchase requisition, error message bbp_pu 231 is issued in the monitor: "Backend system & is not available. Inform system admin."

2.- When creating shopping carts resulting in a purchase order, the PO is created via PI in the backend system, but document status remains always with value I1111, "item in transfer process", and the follow-on document number is not linked with the SC item.

To solve the first issue, we implemented oss notes:

  • 1517301: Prevent 'Commit work' in BAPI_PO_CREATE etc.

and related note:

  • 1522994: "Follow-on document deleted" active although doc was created

With this, the first issue seems to be solved, while the second one remains.

If we change the system type from ERP_4.0 to ERP_3.0, and create new shopping carts resulting in PO in the backend systems, everything works fine: PO gets created in the ECC6 and the corresponding status is updated properly in SRM. We ca not maintain ERP_3.0 as system type, as we need the CPPR scenario and this requires PI and ERP_4.0 system type.

After debugging, we found out that symptom in OSS note 1580629 (released 18.04.2011) exactly match with our problem:

"When a shopping cart, which contains an order line, is transferred to the backend system, a backend follow-on document is created but the system does not maintain the link between the shopping cart and the created follow-on document"

However, this note applies only to SRM_SERVER 550

The error occurs both when transferring SC to backend either directly or from Sourcing

Any clue about this?

Thnaks in advance

Best regards

Valentí

Former Member
Not what you were looking for? View more on this topic or Ask a question