Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Could not load file or assembly 'Interop.SAPbobsCOM, Version=


We recently upgraded our SAP B1 to 8.8, our add-on still remains 2007A and so far it works fine. But when i tried to replace the assembly(UI & DI) in my project from 2007A to 8.8 and run it, then I got this error. During my replacing the assembly SAPbobsCOM and SAPbouiCOM in visual studio 2008, I didn't notice any problem. Below are what I did for the upgrading:

1. I launched my SAP and connect to our new SAP B1 server and was asked to do the upgrading.

2. Once my SAP B1 client upgrade finished then I can login into new version of SAP B1 8.8

3. Then I open my Add-On project and remove the assembly (old ver 2007, UI & DI) then re-add the reference using 8.8

When I run the add-on in debugging mode with my current SAP B1 8.8 client, then I got an errors saying "Could not load file or assembly 'Interop.SAPbobsCOM, Version="

Any idea?

Many thanks!


Not what you were looking for? View more on this topic or Ask a question