Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

BPC Install Error - SM59 - Important


Im new at the Netweaver environment... therefore I need help ASAP because im stuck in the install. I hope you can give me some advice.

Current issue: Guide for BPC NW 7.5 - Configuring the ABAP server component - using transaction SM59 for MDX Parser.

My system: BPC 7.5 SP04, Windows 2008 R2 64bits, SQL Server 2008.

ABAP: EHP1 for Netweaver (SP04), PI_BASIS 7.01, ABA 7.01, SAP BASIS 7.01, SAP BW 7.01, Kernel 64 bit


Downloaded file from : Support package and patches, addit components, sap kernel, sap kernel 64 bit unicode, sap kernel 7.01 64 bit, platform Windows server x64 64bit, #DB independent, librfc_21-10005992.sar

Copied the librfc_21-10005992.sar to Windows/System32 .

On CMD typed: SAPCAR -xvf librfc_21-10005992.sar

SAPCAR: 2 files extracted


At this point... I've read the following notes... and 413708 , 212876, 336693; and it says that the library U does not apply for the procedure im about to perform....

Therefore, can you tell me please which dll to download from Sap.

Once I have the appropiate dll, according to what I've read I have to:

- Rename or backup the current librfc32.dll (original from system)


- Apply SAPCAR again on Windows/System32 and verify its name (without U)

- Register with regsvr32 librfc32.dll or regsvr librfc32.dll

- If the lib is not in the same directory as mdxsvr.exe, copy it in /usr/sap/SID/sys/exe

- Go to SAP, and check that Communication Type with Target is set to Non Unicode.

- Run the test

Is this procedure ok?

Please tell me which .dll to download

Thanx in advance




.dll files for kernel version 7.01 is having some issues. you can use librfc32.dllfor kernel 7.00 which you can get from service market place. just download that file (librfc32.dll) from market place and place it in :/windows/system32 folder. then your MDX PARSER connection should work fine.

note: librfc32.dll is independent for kernel version i.e you can use this file for any kernel version. better to use librfc32.dll of kernel 7.00. (also do not use librfc32u.dll)



0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question