Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Crystal 2008 not working with outlook 2010 mapi when exporting

I recently had service pack 3 and fix pack 3.3 updated to my system ( crystal 2008) to help correct a issue with mapi not populating addresses from outlook when trying to export a report. I have a new issue. - sort of???

Now when I try to export multiple reports in a row I still have the same issue. I can send 1 report out. But if i try to send another report out i have the same issue that I had with mapi not populating the addresses field from outlook.

To get past this I shut down crystal and then bring it back up and I can send (ONE) report again before the same thing happens. Does anyone know if there is fix for this issue?

Fyi - this has nothing to do with the design of my report. The problem lies with how Crystal is communicating with mapi when trying to allowi a 2nd report to be exported. I am not using any outside programs, only crystal 2008 version and trying to export my report through mapi (outlook 2010 (in PDF format). As stated above with the above fixpack - I was able to restore exporting but now I can only export 1 report at a time.

When I select a 2nd report to export (after just sending out my 1st) the mapi function will not allow me to select addresses. So while the fix pack (from the website) restored some functionality it only allows 1 report at a time.

Former Member

Hi Max,

It works for me. I get the Allow for 1 minute box and then I export again and same thing.... works...

I'm using Windows 7 64 bit at home. It just installed SP 1 so that may be the difference also but I don't recall this being a problem before.

I also don't see this being a CR problem, if it works once then something else is blocking the MAPI permission box. Check your anti-virus logs, could be it things a trojan is taking over your address book and blocking the second attempt. The AV logs should show you if something was blocked. Or disconnect from your network/disable network cards and disable your AV and test again.

Do you have any other tool that allows you to export? If you install Winzip or WinRAR it adds a feature that allows you to right click on any file, save the PDF to disk and then test using the zip tool to see if that works for you. If not it's definitely your AV or possibly Firewall software blocking the pop up.

Thanks again


0 View this answer in context
Not what you were looking for? View more on this topic or Ask a question