Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

R3trans -d error

Hi all,

first we cloned the testsystem by copying all the files.

After that I renamed the db and created the ops$user via Note 400241

and now I get the following message when I execute R3trans -d.

0.082587

4 ETW000 [ dev trc,00000] set_ocica() -> SQL code 1403 22

0.082609

4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con_hdl=0, rc=1403) 23

0.082632

4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 1403 119

0.082751

4 ETW000 [ dev trc,00000] ORA-01403: no data found

4 ETW000 48

0.082799

4 ETW000 [ dev trc,00000] Disconnecting from connection 0 ... 23

0.082822

4 ETW000 [ dev trc,00000] Rolling back transaction ... 35

0.082857

4 ETW000 [ dev trc,00000] Closing user session (con_hdl=0,svchp=0x11101abb8,usrhp=0x11109d6e0)

4 ETW000 165

0.083022

4 ETW000 [ dev trc,00000] Now I'm disconnected from ORACLE 637

0.083659

4 ETW000 [ dev trc,00000] Info: 99=DBSL_ERR_DB, oerr=1403, try to connect with default password.

4 ETW000 38

0.083697

4 ETW000 [ dev trc,00000] Connecting as SAPR3/<pwd>@AMP on connection 0 (nls_hdl 0) ... (dbsl 701 140910

)

4 ETW000 37

0.083734

4 ETW000 [ dev trc,00000] Nls CharacterSet NationalCharSet EnvHp

ErrHp ErrHpBatch

4 ETW000 47

0.083781

4 ETW000 [ dev trc,00000] 0 UTF8 0x110ffeee0 0x11

1019138 0x1110189e8

4 ETW000 37

0.083818

4 ETW000 [ dev trc,00000] Assigning username to user session: con_hdl=0, usrhp=0x11109d6e0 26

0.083844

4 ETW000 [ dev trc,00000] Assigning password to user session: con_hdl=0, usrhp=0x11109d6e0 27

0.083871

4 ETW000 [ dev trc,00000] Starting user session: OCISessionBegin(con_hdl=0, usr=SAPR3/<pwd>, svchp=0x111

01abb8, srvhp=0x11101c758, usrhp=0x11109d6e0)

4 ETW000 229

0.084100

4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with -1=OCI_ERROR 3927

0.088027

4 ETW000 [ dev trc,00000] OCISessionBegin(OCI_DEFAULT) failed with SQL error 1017: 69

0.088096

4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 39

0.088135

4 ETW000 [ dbsloci.,00000] *** ERROR => CONNECT failed with sql error '1017' 24

0.088159

4 ETW000 [ dev trc,00000] set_ocica() -> SQL error code 1017 22

0.088181

4 ETW000 [ dev trc,00000] -->oci_get_errmsg (con_hdl=0, rc=1017) 22

0.088203

4 ETW000 [ dev trc,00000] OCIErrorGet -> SQL error code: 1017 56

0.088259

4 ETW000 [ dev trc,00000] ORA-01017: invalid username/password; logon denied

4 ETW000 38

0.088297

4 ETW000 [ dblink ,00433] ***LOG BY2=>sql error 1017 performing CON [dblink#4 @ 433] 73

0.088370

4 ETW000 [ dblink ,00433] ***LOG BY0=>ORA-01017: invalid username/password; logon denied [dblink#4 @ 433

]

4 ETW000 36

0.088406

2EETW169 no connect possible: "DBMS = ORACLE --- dbs_ora_tnsname = 'AMP'"

Can anyone advise me how i set the environment variables for <SID>adm and ora<SID>

thanks

Former Member
Former Member replied

Hello shatti,

ORA-1403 means that no data was fetched. Is the table OPS$AMPADM.SAPUSER empty?

Or maybe you inserted a row but forgot to commit it?

select * from "OPS$AMPADM".sapuser;

Regards,

Mark

1 View this answer in context

Helpful Answer

by
Not what you were looking for? View more on this topic or Ask a question