Skip to Content

Archived discussions are read-only. Learn more about SAP Q&A

Issue with migrated transformation rule after transport

Hello all,

We have migrated couple of update rules and transfer rules to transformation rules. All the transformation rules are active in development environment.

The issue is when we transport these transformation rules to QA, one of the fields of datapacket dimension "RECORD" becomes &R1& in the global structure of start routine and therefore, transport fails in QA. Along with this we had another issue that if we add any additional fields in the cube or ODS structure, the global structure in start routine doesn't change after transport in QA. Basically, it seems like it doesn't do anything when we do transport.

We tried couple of things by transporting entire flow inclding target and source objects, we also tried transporting only transformation with overwrite mode. But none of the things worked. We also have logged the message with SAP.

SAP suggested us to open the QA environment and perform the change manually. We did it and obviously we could activate the transformation rules. But when we tried to re-transport the transformation, it is keep failing with the error "Syntax Error". My assumption has after the transport, the field has become &R1& again.

Has anybody faced such issue? We are on Ehp1 SP7.

- Danny

Former Member
Not what you were looking for? View more on this topic or Ask a question